home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-plugins / xmms-liveice-1.0.0 / xmms-liveice-1.0.0.ebuild < prev   
Text File  |  2005-12-20  |  830b  |  35 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-liveice/xmms-liveice-1.0.0.ebuild,v 1.11 2005/09/14 06:11:57 agriffis Exp $
  4.  
  5. IUSE=""
  6.  
  7. inherit gnuconfig
  8.  
  9. MY_P=LiveIce-${PV}
  10. S=${WORKDIR}/${MY_P}
  11. DESCRIPTION="Stream your XMMS playlist to Shout/Icecast server"
  12. HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
  13. SRC_URI="http://star.arm.ac.uk/~spm/software/liveice-xmms.tar.gz"
  14.  
  15. SLOT="0"
  16. LICENSE="GPL-2"
  17. KEYWORDS="alpha amd64 ppc sparc x86"
  18.  
  19. DEPEND="media-sound/xmms" # there is no need for the icecast on the localhost
  20.                           # see #81132
  21.  
  22. src_unpack() {
  23.     unpack ${A}
  24.     gnuconfig_update
  25. }
  26.  
  27. src_compile() {
  28.     econf || die
  29.     make CXXFLAGS="${CXXFLAGS}" || die
  30. }
  31.  
  32. src_install() {
  33.     make DESTDIR=${D} install || die
  34. }
  35.